مایکت | بازار اندرویدی

زمان‌بندی اعمال محدودیت‌های Target SDK برای توسعه‌دهندگان مایکت

همانطور که احتمالا می‌دانید، گوگل به‌زودی محدودیت‌هایی در Target SDK برنامه‌ها اعمال خواهد کرد. طبق برنامهٔ زمان‌بندی اعلام شده در بلاگ گوگل، از تاریخ ۱۰ مرداد ۱۳۹۸، نصب برنامه‌هایی که Target SDK پایین‌تر از 26 دارند، در دستگاه‌های با اندروید بالاتر از 8، از طرف سیستم‌عامل با هشدار امنیتی مواجه خواهند شد.

به همین دلیل مایکت برای جلوگیری از بروز این خطا برای کاربران و توسعه‌دهندگان، در نظر دارد که توسعه‌دهندگان را به به‌روزرسانی Target SDK برنامه‌های خود (به نسخهٔ 26 و بالاتر) سوق دهد.

از این رو زمان‌بندی اعمال محدودیت‌های Target SDK برای توسعه‌دهندگان مایکت به صورت زیر خواهد بود:

  • ۱۸ خرداد: محدودیت انتشار برنامه جدید با Target SDK پایین‌تر از 26
  • ۱ مرداد: محدودیت انتشار به‌روزرسانی جدید با Target SDK پایین‌تر از 26
  • ۹ مرداد: محدودیت امکان نصب و به‌روزرسانی برنامه‌های با Target SDK پایین‌تر از 26 روی دستگاه‌های اندروید ۸ و بالاتر در مایکت

توجه کنید که از تاریخ ۹ مرداد ۱۳۹۸ برنامه‌هایی که Target SDK پایین‌تر از 26 دارند، برای کاربران با دستگاه‌های بالاتر از اندروید 8، ناسازگار خواهد بود. بنابراین با توجه به سرعت رشد نسخه‌های جدید اندروید ومحدودیت‌های فعلی Google Play Protect، پیشنهاد می‌شود که هرچه سریع‌تر اقدام به به‌روزرسانی Target SDK نمایید.

در نظر داشته باشید که برای به‌روزرسانی Target SDK، حتما «مستند نیازمندی‌های مهاجرت به نسخه‌های جدید Target SDK» را بخوانید.

  • وحید رحیمیان
  • سه شنبه ۷ خرداد ۹۸
  • ۱۶:۳۲
احمد
اگر امکان ترجمه مستند نیازمندی‌های مهاجرت به نسخه‌های جدید توسط تیم ارجمند مایکت برای کاربران فارسی وجود داشت کار برای برنامه نویسان و توسعه دهندگان آسان تر می شد.
niloofar ziba
با تشکر از اینکه از قبل در مورد این تغییرات اطلاع رسانی کردید. مثل همیشه مایک بهترین است.
ارسال نظر آزاد است، اما اگر قبلا در بیان ثبت نام کرده اید می توانید ابتدا وارد شوید.
تجدید کد امنیتی